FXCM Forex Trading

SDK updates. Subscribe to be informed!!!

Moderator: admin

Re: SDK updates. Subscribe to be informed!!!

Postby tllewell » Tue Jan 12, 2016 8:20 am

Is the new TS supposed to be supported by SDK version 3? It looks like you've updated everything but there does not seem to be an announcement or a production version of Indicore v3. What's going on? Between the flakey data feed that took two days to fix and problems with existing strategies and indicators and no clear explanations of what is going on, I'm wondering if this platform is stable enough to keep working with.

Are we supposed to update the SDK we are working with or not? If so, where is the download? Or is it already there and still labelled as version 2.3? Maybe I've missed an announcement, but I've been looking around and it it's out there, it's not very obvious.
tllewell
 
Posts: 76
Joined: Thu Mar 01, 2012 4:06 pm

Re: SDK updates. Subscribe to be informed!!!

Postby Spidey » Tue Jan 12, 2016 1:59 pm

I second everything tllewell has said (about ten times over) about the sdk versions as well as the io error. It is definitely broken. My strategies wont run and I'm unable to trade. Sending private messages to tllewell doesn't help anybody else having the same problem.

tllewell did u sort your io problem?

The following code fails:

for line in handle:lines() do

with attempt to call method 'lines' (a nil value).
Spidey
 
Posts: 15
Joined: Thu Mar 14, 2013 8:58 am

Re: SDK updates. Subscribe to be informed!!!

Postby Julia CJ » Wed Jan 13, 2016 6:51 am

Indicore 3.0 hotfix build has been released.
Download it from:
http://www.fxcodebase.com/bin/beta/Indi ... reSDK3.exe

Here is what's new in this build:

It contains fixes of some bugs found in Indicore SDK. Please note that the
current production version of TS 01.14.112415 has been built using an older Indicore SDK version
and it may not contain all the following fixes.

1) Indicore SDK now supports binary files and w+ file open mode in io.open.
http://www.fxcodebase.com/code/viewtopi ... 96#p102196
This fix is included in the current production TS version.

2) The Indicore Debugger crash with owner drawn indicators has been fixed.
http://www.fxcodebase.com/code/viewtopi ... 88#p103988
This defect does not affect TS.

3) The io.lines(filename) Lua function shows an error when done reading a file.
http://www.fxcodebase.com/code/viewtopi ... 53#p104253
This fix is not included in the current production TS version.
Julia CJ
 

Re: SDK updates. Subscribe to be informed!!!

Postby tllewell » Wed Jan 13, 2016 7:14 am

So when is the TS that appeared Sunday afternoon going to be replaced? All of the input functions of the Lua IO library appear to be broken. io.read() (in any mode), io.lines(); nothing works. I even tried io.popen, which I am not sure even works on Windows. Major parts of the systems I've built over the last two years are broken and most of my trade management does not work.

Why in the world would you break parts of the way the language works? It's not the core language, but people sort of expect the standard libraries to work.

And the private message that Julia said she sent to me did not appear in my inbox, so I don't know what she said. I should have said something, but at the time I became more concerned over the way getSyncHistory had been broken than the way the IO library had been broken. Since I never saw an update to the beta that appeared to address any of these issues I never circled back.
tllewell
 
Posts: 76
Joined: Thu Mar 01, 2012 4:06 pm

Re: SDK updates. Subscribe to be informed!!!

Postby Julia CJ » Thu Jan 14, 2016 8:41 am

Hello Tllewell,

All of the input functions of the Lua IO library appear to be broken. io.read() (in any mode), io.lines(); nothing works. I even tried io.popen, which I am not sure even works on Windows. Major parts of the systems I've built over the last two years are broken and most of my trade management does not work.

Why in the world would you break parts of the way the language works? It's not the core language, but people sort of expect the standard libraries to work.


We try to provide maximum compatibility with standard Lua libraries, but sometimes we need to change standard functions. For example, we had to make our own implementation of io functions to support Indicore packages (indicators can read files directly from packages) and secure user data (starting from the next TS version, users will be able to restrict access of indicators to the file system). Unfortunately, the current implementation has errors that have not been detected in time. In fact, even in the current production TS version you can work with files via io functions, but you need to use non-standard read modes.

In attachment you will find an indicator that displays currently supported modes. This indicator was tested on a production version of the Trading Station.

I should have said something, but at the time I became more concerned over the way getSyncHistory had been broken than the way the IO library had been broken.


Could you explain what exactly the problem is with getSyncHistory?
Our test and PIVOT indicators that use this function work fine.

Unfortunately, despite our thorough testing, sometimes we miss errors.
We usually pre-release TS DEV versions with new functionalities so that developers of indicators and strategies could check them for compatibility with new versions and we could fix bugs before releasing to production.
We would be very grateful for any feedback on using Dev versions and for messages about any bugs you see. They help us improve qualityof our product and reduce the number of possible problems.
Attachments
i_file_lines.lua
(2.35 KiB) Downloaded 231 times
Julia CJ
 

Re: SDK updates. Subscribe to be informed!!!

Postby tllewell » Thu Jan 14, 2016 9:32 am

I'll look at this code and see if it works.

The comment about getSyncHistory was past tense. I found problems with IO but since the issue with getSyncHistory made worrying about IO problems pointless, I concentrated on that. There was never a reply anywhere that said getSyncHistory is fixed, please test.

The web site and forums are not very well organized. There should be a download page where you can find current and previous versions of all of the SDKs, indicating when they were updated. File names should indicate version numbers. Right now there really is not clear way to know when things change or what is going on.

I was already working on getting off of Indicore, and this whole episode just motivates me. None of the other APIs look like they are very current (the .NET API calls for a very old version of .NET, and the Java API still doesn't support OpenJDK?). There don't seem to be any good options, though.
tllewell
 
Posts: 76
Joined: Thu Mar 01, 2012 4:06 pm

Re: SDK updates. Subscribe to be informed!!!

Postby tllewell » Thu Jan 14, 2016 4:57 pm

Julia, is that example you attached supposed to do something? Most of the functions are indicated as not working. The one that does not say "this doesn't work" includes the line

Code: Select all
local line = handle:read(mode);


and as I've already indicated, io.read() does not work at all. Your example is no different. I loaded a text file into it that said "test" and when I hit OK I got this:

An error occurred during the calculation of the indicator 'I_FILE_LINES'. The error details: C:/Candleworks/FXTS2/Indicators/Custom/i_file_lines.lua:63: function which is running longer than 30 seconds detected.


So I'm not sure what your example is supposed to do. Likewise I'm not sure what crippling the IO library is supposed to do. I liked the note about how in the future we'd be able to restrict access to files. Seems like you've already done that pretty thoroughly.
tllewell
 
Posts: 76
Joined: Thu Mar 01, 2012 4:06 pm

Re: SDK updates. Subscribe to be informed!!!

Postby Alexey.Pechurin » Fri Jan 15, 2016 2:45 am

Hello tllewell,

The comment about getSyncHistory was past tense. I found problems with IO but since the issue with getSyncHistory made worrying about IO problems pointless, I concentrated on that. There was never a reply anywhere that said getSyncHistory is fixed, please test.


This problem was fixed. Your test indicator works in the current TS version.

The web site and forums are not very well organized. There should be a download page where you can find current and previous versions of all of the SDKs, indicating when they were updated. File names should indicate version numbers. Right now there really is not clear way to know when things change or what is going on.


We'll think how to better organize storing the history of all Indicore releases.

None of the other APIs look like they are very current (the .NET API calls for a very old version of .NET, and the Java API still doesn't support OpenJDK?). There don't seem to be any good options, though.


We are working on updating of Integration APIs (C#, C++, Java) to the current Indicore version. But it requires a lot of work. I'm afraid we need few monthes to complete it.

An error occurred during the calculation of the indicator 'I_FILE_LINES'. The error details: C:/Candleworks/FXTS2/Indicators/Custom/i_file_lines.lua:63: function which is running longer than 30 seconds detected.


You either provide an empty file (it's a known issue) or use some unsupported mode. In the current TS version you can use
"a" instead of "*a"/"*all"
"l" instead of "*l"/"*line"

Thank you for report and sorry for inconvinience.

Alexey
Alexey.Pechurin
 
Posts: 97
Joined: Sun Jul 22, 2012 11:26 pm

Re: SDK updates. Subscribe to be informed!!!

Postby tllewell » Fri Jan 15, 2016 7:26 am

Alexy,

TS version you can use
"a" instead of "*a"/"*all"
"l" instead of "*l"/"*line"


Yes, that appears to work (so far I've only tested one of the modes). Thank you.

And just one final comment on the Java SDK: I'm not a professional programmer, but shouldn't the Java SDK support OpenJDK? OpenJDK seems to be pretty mainstream these days.
tllewell
 
Posts: 76
Joined: Thu Mar 01, 2012 4:06 pm

Re: SDK updates. Subscribe to be informed!!!

Postby moomoofx » Wed Jan 20, 2016 10:14 pm

Hello Everyone,

I come out of the woodwork because this latest version of the TS2 has created some problems for some previous clients of mine.

The problem appears to be with the file table (http://www.fxcodebase.com/bin/beta/Indi ... -file.html) and missing functions related to this class. For example, setvbuf() and flush() no longer work. The error is...

ERROR " attempt to call method 'flush' (a nil value)" in file ...
ERROR " attempt to call method 'setvbuf' (a nil value)" in file ...

Has anyone else experienced this problem with the new SDK?

Looking forward to your help.

Regards,
MMFX
User avatar
moomoofx
FXCodeBase: Confirmed User
 
Posts: 193
Joined: Wed Oct 23, 2013 10:26 pm
Location: Okinawa, Japan. http://moomooforex.com

PreviousNext

Return to Indicator Development

Who is online

Users browsing this forum: Google [Bot] and 2 guests